[Haskell-cafe] Problems installing HDBC-postgresql

Martin Percossi haskell-cafe at martinpercossi.com
Mon Jul 10 07:01:37 EDT 2006

Hi, I'm having problems using HDBC-postgresql (I've tried both 
and with postgresql (version 8.1.4, installed in /share/pgsql). 
I adjust the include-dir and extra-lib-dirs to use the custom location 
of postgresql, and build: no error messages, everything seems fine.

However, when I then try to type:
ghci -package HDBC -package HDBC-postgresql
, I get the error message:
Loading package HDBC-postgresql- ... linking ... ghc-6.4.2: 
unknown symbol `PQserverVersion'
ghc-6.4.2: unable to load package `HDBC-postgresql-'

Has anyone seen this error message before? Google didn't turn up 
anything relevant to haskell -- however there does seem to be a 
PQserverVersion procedure in the libpq library -- maybe HDBC-postgresql 
is not seeing this due to the custom install location?


More information about the Haskell-Cafe mailing list