"interact" behaves oddly if used interactively
olaf at cs.york.ac.uk
Thu Oct 2 20:04:56 EDT 2003
> So... you agree that getContents in its current form should really be
> called unsafeGetContents? Unless perhaps we redefine its semantics to
> either (a) yield a random string or (b) eagerly slurp the entire stream
Well, I'm not sure that the semantics of getContents is currently
clearly defined and I'm not sure what the prefix `unsafe' really means.
However, I don't want to continously disagree with you.
unsafeGetContents would have been a better name.
Dept. of Computer Science, The University of York, York YO10 5DD, UK.
Tel: +44 1904 434756; Fax: +44 1904 432767
More information about the Haskell-Cafe