Problems with installing dph

Jan Clemens Gehrke jcg at
Tue Aug 13 13:40:37 CEST 2013

Hi Glasgow-Haskell-Users,

I'm trying to get started with DPH and have some problems.
If i try getting DPH with
cabal install dph-examples
I get to warnings numerous times. The first warning is:

You are using a new version of LLVM that hasn't been tested yet!
We will try though...

and the second one:

Warning: vectorisation failure: identityConvTyCon: type constructor 
contains parallel arrays [::]
   Could NOT call vectorised from original version

Cabal finishes with:

Installing executable(s) in /home/clemens/.cabal/bin
Installed dph-examples-

If i try compiling the first example from
ghc -c -Odph -fdph-par DotP.hs
i get
ghc: unrecognised flags: -fdph-par

I'm running
ghc version 7.6.3
cabal-install with version 1.16.0 of the cabal library
llvm 3.3-1
on a Linux (Manjaro) System.

Thanks in advance for any help

Jan Clemens Gehrke
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Glasgow-haskell-users mailing list