Chris Dornan chris at
Thu Jul 28 14:29:24 CEST 2011

Hi All,


I have been trying to get a simple-integer build for GHC without success. It
always ends with the build going through fine, but when I try to run ghci I


GHCi, version 6.12.3:  :? for help

Loading package ghc-prim ... linking ... done.

ple- unknown symbol `base_ControlziExceptionziBase_patError_info'

Loading package integer-simple ... linking ... ghc: unable to load package


My MO is to


.         get binary GHC package, install it and put it on the path;

.         unpack the source distribution and set up, usually with
quicktest, always with INTEGER_LIBRARY = integer-simple;

.         configure, build and install;

.         switch the path over from the binary to the new build and run


I have tried this many combinations of build and source trees from
ghc-6.12.1 up to 7.0.4 on CentOS/RHEL 5 & 6 with the same result.


The above output was taken from a 6.12.3 source tree built with 6.12.2




.         I use 6.12.3 binaries heavily on CentOS 5 with no issue.

.         On the couple of occasions I have tried a vanilla build (no, the build breaks down with GMP link errors. Configuring with
--with-gmp-includes=/usr/local/include  and --with-gmp-libs=/usr/local/lib
didn't help. (I did not persist for obvious reasons.)

.         At least Mik Konecny appears to got this to work for 6.12.3
<> .


'Tis all very odd! Anybody any idea what I am doing wrong?





-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Glasgow-haskell-users mailing list