build issue: * Missing header file: HsBase.h

Duncan Coutts duncan.coutts at
Thu Dec 16 11:16:36 CET 2010

On 16 December 2010 10:02, Simon Marlow <marlowsd at> wrote:

>> ghc-cabal: Missing dependency on a foreign library:
>> * Missing header file: HsBase.h
>> This problem can usually be solved by installing the system package that
>> provides this library (you may need the "-dev" version). If the library is
>> already installed but in a non-standard location then you can use the
>> flags
>> --extra-include-dirs= and --extra-lib-dirs= to specify where it is.

>> The problem is HsBase.h is where it is on my reference build tree on
>> workstation:
>> -bash-4.0$ find . -name 'HsBase.h'
>> ./libraries/base/include/HsBase.h

>> I suppose some external library might be missing, but here the error is
>> quite misleading and I cannot find which one might be the culprit of
>> this error.
>> Do you have any idea what to install in order to proceed?
> I don't know what's going on here, I'm afraid.  Looks like Cabal tried to
> find HsBase.h and couldn't find it - so either it wasn't there (but you say
> it was), or Cabal was looking in the wrong place.  Maybe follow up the
> latter hypothesis?

Cabal will report this error when it cannot compile HsBase.h, that
usually means it is missing, but it's also possible that something
just does not compile. This is like the check that ./configure scripts
do. It's rather hard from the exit code of gcc to work out if it's
genuinely missing, or fails to compile (though we could try doing cpp
and cc phases separately).

One can run with -v3 to see the error that gcc reports.


More information about the Glasgow-haskell-users mailing list