Can't install Criterion package on ghc ..

Mozhgan kabiri mozhgan.kabiri at
Wed Apr 14 15:05:00 EDT 2010

On Wed, Apr 14, 2010 at 7:22 PM, Bryan O'Sullivan <bos at>wrote:

> On Wed, Apr 14, 2010 at 10:49 AM, Mozhgan kabiri <mozhgan.kabiri at
> > wrote:
>> Thanks for the replies .. I upgraded ghc to ghc 6.12 .. and installed
>> Criterion through cabal .. There is another problem here which I really
>> don't know if it is due to the ghc version or the dependencies or my OS
>> version !!!
> There hasn't been an official release of gtk2hs that supports GHC 6.12.1
> yet, and gtk2hs is a nightmare on the Mac anyway. Unfortunately, this means
> that you get to produce CSV files and generate the charts yourself for now.
> Someone sent me a gnuplot patch for criterion, but I haven't reviewed it
> yet.

Hi Bryan ..

Actualy by the term OS , I meant my operating system is ubuntu 9.10 .. still
gtk2hs will not work on my machine ? The thing is , I was told that
Criterion package will not work on ghc 6.10 and I have to upgrade it to ghc
6.12 .. still it doesn't plot anything as an output .. What I don't
understand it that, do I really need this gtk2hs in order to use the
Criterion package and get it to work ?? If yes, then why one can't work with
ghc 6.12 and one can't work with the older version ?

Could you please help me out .
Thanks ..
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the Glasgow-haskell-users mailing list