Can't install Criterion package on ghc ..

Bryan O'Sullivan bos at
Wed Apr 14 14:22:52 EDT 2010

On Wed, Apr 14, 2010 at 10:49 AM, Mozhgan kabiri
<mozhgan.kabiri at>wrote:

> Thanks for the replies .. I upgraded ghc to ghc 6.12 .. and installed
> Criterion through cabal .. There is another problem here which I really
> don't know if it is due to the ghc version or the dependencies or my OS
> version !!!

There hasn't been an official release of gtk2hs that supports GHC 6.12.1
yet, and gtk2hs is a nightmare on the Mac anyway. Unfortunately, this means
that you get to produce CSV files and generate the charts yourself for now.

Someone sent me a gnuplot patch for criterion, but I haven't reviewed it
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the Glasgow-haskell-users mailing list