Attempts to install libraries with GHC 6.12.1rc1

Simon Marlow marlowsd at
Tue Oct 13 06:50:47 EDT 2009

On 13/10/2009 11:17, Neil Brown wrote:
> Hi,
> I downloaded the new GHC release candidate. It compiled and installed
> first time, which was great. However, this is not true of all the
> libraries. I'm posting here in the hope that it helps other users trying
> to get it to work, or library maintainers to see what breaks in the new
> compiler. I know most people should wait for the Haskell platform, but
> I'm happy to jump through hoops to try the release candidate.
> So, after installing GHC, I tried to bootstrap cabal-install with the
> script, but that told me it required parsec and network. (I
> have since seen a post on this list that cabal-install won't work, but
> anyway....) Parsec (and mtl, which it needed) installed fine with
> 6.12.1-rc1. The network package said:
> Network/Socket.hsc:1707:45:
> Not in scope: data constructor `System.Posix.Internals.Stream'
> (I also tried the latest version of network from the darcs repository,
> but that said:
> Warning: defaultUserHooks in Setup script is deprecated.
> Configuring network-
> Warning: The 'build-type' is 'Configure' but there is no 'configure'
> script.
> Setup.hs: Missing dependency on a foreign library:
> * Missing header file: HsNet.h
> Even though HsNet.h is in the include directory already... odd.
> )

network is one of those packages that has a configure script, but the 
configure script is generated by autoconf from, so it is 
not stored in the darcs repository.  When you get the network package 
from darcs, you need to

  $ autoreconf
  $ runhaskell Setup configure

> Anyway, it looked like that Posix module was in the unix library, so I
> thought I'd install that. That said:

unix is supplied with GHC 6.12, you shouldn't need to install it yourself.

> Preprocessing library unix-
> gcc: unrecognized option
> '-R/home/nccb2/lib/ghc-'
> gcc: unrecognized option
> '-R/home/nccb2/lib/ghc-'
> gcc: unrecognized option
> '-R/home/nccb2/lib/ghc-'
> gcc: unrecognized option '-R/home/nccb2/lib/ghc-'
> gcc: unrecognized option '-R/home/nccb2/lib/ghc-'
> #... Above 5 lines repeated a lot of times
> #gcc --version is 4.3.3
> Building unix-

Fascinating ... I also get these complaints about -R.  I'll look into it.

> dist/build/System/Posix/Signals.hs:127:0:
> error: Signals.h: No such file or directory

Again I suspect this is because you need to run 'autoreconf' before 


More information about the Glasgow-haskell-users mailing list