Unable to compile ghc from darcs

Simon Marlow marlowsd at gmail.com
Tue Mar 31 10:56:52 EDT 2009

Donnie Jones wrote:
> Hello Simon and Colin,
> This information is available on the Prequisites page of the GHC wiki;
> however, it's buried at the bottom of the page.  I have updated the
> page to mention that a stable release version of GHC is needed when
> setting up for Linux and Windows, and I have changed the "Other"
> section to be called "Details" since this section describes in detail
> the software necessary for building GHC.
> http://hackage.haskell.org/trac/ghc/wiki/Building/Prerequisites

Thanks Donnie.  I've also just modified the configure script so it issues 
the following helpful message:

configure: error:
      /home/simonmar/builds/testing/ghc/stage2-inplace/ghc is a development 
snapshot of GHC, version 6.11
      Bootstrapping using this version of GHC is not supported, and may not
      work.  Use --enable-bootstrap-with-devel-snapshot to try it anyway,
      or --with-ghc to specify a different GHC to use.


More information about the Glasgow-haskell-users mailing list