Cygwin version

John Meacham john at
Mon Mar 9 08:36:41 EDT 2009

On Sun, Mar 08, 2009 at 11:46:07PM +0000, Tuomo Valkonen wrote:
> No:
>     Configuring extensible-exceptions-
>     cabal-bin.exe: Cannot find the program 'ghc' at
>     '/c/bin/ghc-' or on the path
> 'ldd libraries/cabal-bin.exe' finds no cygwin dependencies;
> everything points to /c/WINDOWS/system32. I presume that
> the mingw-ghc used the include mingw gcc, not cygwin's gcc.
> Indeed, I tried deleting that file, and got: 
>     ghc.exe: could not execute: C:\bin\ghc-\gcc
> It doesn't seem like it will build cygwin programs.

perhaps the most recent non-cabalized ghc build might be worth a try. I
think darcs still compiles with ghc 6.6, but am not positive., I seem to
remember ghc working on cygwin at some point. I have been in a similar
position in the past actually in the odd place of developing linux/unix
software while sitting at a windows box, and cygwin builds of tools were
more useful in general.


John Meacham - ⑆⑆john⑈

More information about the Glasgow-haskell-users mailing list