(alpha) "stick shift" cabal install for GHC 6.12.1

Antoine Latter aslatter at gmail.com
Fri Dec 18 08:27:55 EST 2009

On Thu, Dec 17, 2009 at 4:00 PM, Dave Bayer <bayer at cpw.math.columbia.edu> wrote:
> Background: I never got "cabal install" to work on OS X 10.5 with GHC 6.10.4, basically because zlib wouldn't work. Odd, because a perfectly good version of gunzip already exists on most platforms, and the code doesn't fall back to this version if needed.

Do you have any more information about this failure? It seems like it
would be easier to get zlib to work than to replicate cabal-install.

My painful story of getting zlib to work on 10.6 is chronicled here:

But my problem should only have been an issue on OS X 10.6, not any
version lower.


More information about the Glasgow-haskell-users mailing list