ANNOUNCE: GHC version 6.12.1

Malcolm Wallace malcolm.wallace at
Mon Dec 14 10:11:46 EST 2009

> I've the 6.10.4 version installed on my MacOS X 10.6 OS. Have I to  
> uninstall this version of GHC before installing the Mac .pkg for the  
> 6.12.1?

Most installer packages (_except_ for MacOS) allow you to have  
multiple previous versions of ghc - they are simply left in place (but  
must now be accessed as e.g. ghc-6.10.4 rather than plan ghc, which  
now points to the new version).

However, there is an unfortunate feature/bug of the MacOS installer  
packages that they forceably delete any previous versions of ghc that  
you had on your machine.  This is undesirable for many reasons, but as  
far as I know, it has not yet been fixed.


More information about the Glasgow-haskell-users mailing list