Running GHC 6.10.* on OpenBSD

Thanos Tsouanas thanos at
Fri Dec 11 22:30:44 EST 2009

Hello list.

Up to now I've only used binary versions of GHC, but since
my operating system's (OpenBSD) version of GHC is
lagging behind (currently at 6.6.1), I need to update it.
I tried using my system's ghc-6.6.1 to compile ghc-6.10.4
but it failed due to haskeline not being installed (and trying
to install it also failed).

I managed (woohoo!) to compile 6.8.3 using 6.6.1, but I
could still not use 6.8.3 to compile 6.10.4.  Even though I
have installed haskeline using cabal in 6.8.3, the making
of 6.10.4 breaks with the (weird?) message:
cabal-bin: At least the following dependencies are missing:
haskeline -any

On the same machine (it's a laptop), I also have a partition
with ubuntu linux installed (which has ghc-6.10.4 installed).
So I thought I should try cross compiling, following the
instrucions at the Porting wiki page. But this also failed at
the first steps, with the complaint:
GHC configuration does not support differing host/target
(i.e. cross-compiling).

Any suggestions / website links?

Also, I understand what --host and --target are supposed to
be, but I'm not clear on --build.  Is there a more detailed
document on building GHC, other than the Porting wiki?


P.S.  I don't really use the ubuntu linux partition, so if
there is an easier alternative that needs to install another
system, I can do it over ubuntu's partition.

Thanos Tsouanas

More information about the Glasgow-haskell-users mailing list