Duncan Coutts duncan.coutts at
Mon Oct 20 14:15:39 EDT 2008

On Mon, 2008-10-20 at 16:28 +0200, Christian Maeder wrote:
> Hi,
> currently I've got a problem installing from hackage.
> using:
>   GHC (package manager) version
>   cabal-install version 0.6.0
>   using version of the Cabal library
> I get:
> Building network-
> Network/URI.hs:128:7:
>     Could not find module `Data.Generics':
>       it is a member of package base-, which is hidden

The basic problem here is that the version number of the network package
has not been bumped. You probably installed from a ghc bindist that has
network- already, however it's not the same as network-
from hackage. The pre-installed one is built against base-4, so when
cabal-install tries to rebuild it then it tries to build it against base
4 which does not work because the one on hackage has not been updated.
Normally cabal-install would use base-3 but in this case it's picking 4
because the version that is already installed used 4 so the assumption
is that since the same version is already installed then it does indeed
work with base 4. Of course that's not true here because the package has
changed without the version being bumped.

Indeed the only reason it's trying to rebuild it at all is because the
installed version has different deps from the available version, again
due to the fact that it changed without changing version number.

So the solution is for the updated network package to have its version
bumped and for it to be released.


More information about the Glasgow-haskell-users mailing list