Christian Maeder Christian.Maeder at
Wed Nov 12 04:59:32 EST 2008

James Swaine wrote:
> I can't seem to get the latest source bundle to build (running on Red
> Hat).  I run the configure script, then make on the source tree root,
> and ghc gives an error to the effect of 'could not load shared object
> file or library'.  I don't have root permissions on this
> machine so I can't install editline on this machine, but I downloaded
> the source, built in my local directory, then tried:
> -Setting the LD_LIBRARY_PATH environment variable to include the
> directory path to the library I just built.

Set LIBRARY_PATH and CPATH to your local lib resp. include directory
when building. (LD_LIBRARY_PATH is used at runtime)

Cheers Christian

> -Hand editing the makefile in ghc's 'libraries' directory to add an
> -L[librarydir] flag to the ghc invocation that was failing.
> Neither of these things worked - is there an easy way to tell the
> configure script that it needs to probe additional directories for these
> shared libraries?
> Thanks all!
> -James Swaine
> ------------------------------------------------------------------------
> _______________________________________________
> Glasgow-haskell-users mailing list
> Glasgow-haskell-users at

More information about the Glasgow-haskell-users mailing list