ANNOUNCE: GHC version 6.10.1 - EditLine / terminal incompatibility?

Rohan Drape rohan.drape at
Sat Nov 8 22:13:03 EST 2008

On 2008-11-09, Reiner Pope <reiner.pope at> wrote:
> I'm not sure if this is Emacs' fault, but when I run GHCi through
> Emacs, entered text is printed to stdout or stderr immediately after
> Enter is pressed; when this is done after a file is loaded, "^J" is
> appended. 

Also here, and there is a further problem with long lines.  

Emacs sends text to processes in packets of at most 255 characters.
In between these ghci now gets a ^D character sequence inserted into
the text.  This did not happen previously (ie. with 6.8.2).

I've edited the emacs mode I use to split long strings into packets
before requesting emacs sends them, which has 'solved' the problem
here.  However it seems unlikely that emacs is doing anything too odd?


(I doubt this affects many people, the emacs mode I use collapses a
region written without layout into a single long line and sends that
to ghci for evaluation.)

More information about the Glasgow-haskell-users mailing list