problem with GHC installaion on x86_64

Yu Di diyu60607 at
Fri Jan 11 08:39:20 EST 2008

Thanks! The clean rebuild worked.

Di, Yu

----- Original Message ----
From: Simon Peyton-Jones <simonpj at>
To: Yu Di <diyu60607 at>; Bryan O'Sullivan <bos at>
Cc: "glasgow-haskell-users at" <glasgow-haskell-users at>
Sent: Thursday, January 10, 2008 3:18:39 AM
Subject: RE: problem with GHC installaion on x86_64


 _filtered {font-family:Calibri;panose-1:2 15 5 2 2 2 4 3 2 4;}
 _filtered {font-family:Tahoma;panose-1:2 11 6 4 3 5 4 4 2 4;}
/* Style Definitions */
 p.MsoNormal, li.MsoNormal, div.MsoNormal
	{margin:0cm;margin-bottom:.0001pt;font-size:12.0pt;font-family:"Times New Roman", "serif";}
a:link, span.MsoHyperlink
a:visited, span.MsoHyperlinkFollowed
	{font-family:"Calibri", "sans-serif";color:#1F497D;}
 _filtered {margin:72.0pt 72.0pt 72.0pt 72.0pt;}

This is a fixed bug


However I hadn’t realised that it’s in 6.8.2; I thought we’d
fixed it prior to the 6.8.2 release.


The workaround is simple: do a “make clean”.  (That’s why our
tests didn’t pick it up; they all start from clean.)




From: glasgow-haskell-users-bounces at
[mailto:glasgow-haskell-users-bounces at] On Behalf Of Yu Di

Sent: 09 January 2008 21:47

To: Bryan O'Sullivan

Cc: glasgow-haskell-users at

Subject: Re: problem with GHC installaion on x86_64


Hi, I found that the x86_64
binary package for version 6.4.1 can be installed successfully on my machine
(the x86_64 builds for higher versions either require or have
problems with timer_create), and then I tried to use that to compile 6.8.2 from
source, but I got the following problem:

make[2]: Entering directory `.../ghc-6.8.2/libraries/base'

../../compiler/stage1/ghc-inplace -package-name base- -hide-all-packages
-split-objs -i -idist/build/autogen -idist/build -i. -Idist/build -Iinclude
-#include "HsBase.h" -odir dist/build -hidir dist/build -stubdir
dist/build -package rts-1.0 -O -fglasgow-exts -package-name base -XCPP
-idist/build  -H16m -O -O -Rghc-timing -fgenerics -c Control/Concurrent.hs
-o dist/build/Control/Concurrent.o  -ohi dist/build/Control/Concurrent.hi

ghc-6.8.2: panic! (the 'impossible' happened)

  (GHC version 6.8.2 for x86_64-unknown-linux):

        lookupVers1 base:GHC.Prim sym{tc}

Please report this as a GHC bug:

<<ghc: 107290456 bytes, 19 GCs, 3592250/7424504 avg/max bytes residency
(3 samples), 20M in use, 0.00 INIT (0.00 elapsed), 0.17 MUT (0.23 elapsed),
0.06 GC (0.07 elapsed) :ghc>>

What is this problem? (I can use 6.4.1 but my programs were last developed with
6.8.1 and contains some function calls that are added later, so I would prefer
to use 6.8.1 and above) Thanks,

Di, Yu



----- Original Message ----

From: Bryan O'Sullivan <bos at>

To: Yu Di <diyu60607 at>

Cc: glasgow-haskell-users at

Sent: Tuesday, January 8, 2008 10:07:16 PM

Subject: Re: problem with GHC installaion on x86_64

Yu Di wrote:

> Hi, I am trying to use ghc on a 64-bit machine (uname -a shows: Linux

> ... 2.6.9-55.ELsmp #1 SMP Fri Apr 20 16:36:54 EDT 2007 x86_64 x86_64

> x86_64 GNU/Linux),

Since you're using RHEL4, you could try grabbing a GHC source RPM for

Fedora and building that.  It might take a bit of tweaking, but probably

very little.  (For instructions on building binary RPMs from source,

Google around.)




Never miss a thing. Make Yahoo
your homepage. 

Never miss a thing.  Make Yahoo your home page.
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the Glasgow-haskell-users mailing list