Any Debian Etch packages for GHC 6.8.2?

Ravi Nanavati ravi at
Tue Jan 8 14:38:17 EST 2008

On Jan 8, 2008 5:23 AM, Wagner Ferenc <wferi at> wrote:
> "Ravi Nanavati" <ravi at> writes:
> Hmm.  I couldn't find 6.8 stuff on Haskell Unsafe at all.  Where is
> it?  Don't you mean Sid instead?  Ian uploaded 6.8.2 the day before
> yesterday...  Maybe when he's finished with this work, a rebuild on
> Etch won't be too difficult.

No. I meant Haskell Unsafe. I built the packages I spoke of last week
(there was an earlier upload, as I recall). The binary packages are
only there for amd64, but since I was building from source anyway,
that didn't make a difference.

> I think it's better to wait a little bit for the dust to settle, maybe
> Ian will also provide some info on this subject.  But thanks for the
> offer, I'll ask you for the packages if that will seem like the best
> route.

If they're in unstable, that helps. The tricky thing turns out to be
that some of 6.8.2's build-deps are only in unstable as well (like the
most recent haddock), so you need to spend some time chasing down and
building dependencies. That's certainly easier if you're not jumping
back between unstable and Haskell Unsafe as I was.

 - Ravi

More information about the Glasgow-haskell-users mailing list