Unrecognized -F flag

Christian Maeder Christian.Maeder at dfki.de
Fri Jan 4 05:40:11 EST 2008

Thanks, for your report. It was my fault. I should not have modified
utils/hsc2hs/Main.hs as described in the following links.


A fix is to replace your file <prefix>/lib/ghc-6.8.2/hsc2hs-bin with a
new one that you can download from:
(635468 Bytes)

a ppc version from:
(800044 Bytes)

<prefix> above is /usr/local (or the one you've configured with)

Does someone have a cute command to easily update this file in a binary
distribution (without unpacking and repacking), so that Ian can replaced
my binary-dists (replacing hsc2hs-bin manually is a bit of a pain).


Adam Smyczek wrote:
> Hi Christian,
> I'm using your OS X (Tiger) Intel ghc-6.8.2 distribution downloaded from
> haskell.org.
> So far everything worked great until I run into one problem compiling
> zlib
> Running build command I get the following error:
> Preprocessing library zlib-
> ghc-6.8.2: unrecognised flags: -F/Users/asmyczek/Library/Frameworks
> Usage: For basic information, try the `--help' option.
> compiling dist/build/Codec/Compression/Zlib/Stream_hsc_make.c failed
> command was: /opt/local/bin/ghc -c -package base- -package
> bytestring- -F/Users/asmyczek/Library/Frameworks
> dist/build/Codec/Compression/Zlib/Stream_hsc_make.c -o
> dist/build/Codec/Compression/Zlib/Stream_hsc_make.o
> I'm newbie to Haskell, Cabal etc. and not sure what the root cause of
> this problem is.
> Google did not find any concrete solution as well.  Do you have an idea
> what the problem
> could be or maybe some hints where I can start to dig into?
> Thanks,
> Adam

More information about the Glasgow-haskell-users mailing list