GHC build failures on Mac OS X Leopard: ppc & x86

Manuel M T Chakravarty chak at
Mon Feb 18 04:19:54 EST 2008

Sean Leather:
> I tried to build GHC "stable" on my two computers, a PowerBook G4 and
> a MacBook, both running 10.5.2. This is the first time I've ever
> tried, so I'm somewhat clueless about a lot of it. I went with the
> basic instructions (./configure; make) with no 'mk/' and no
> configure options other than '--prefix'.
> The MacBook build apparently completed stage1 and failed in trying to
> build stage2 (i.e. "-o stage2/ghc-inplace").

I can't help you with the PPC, but on the MacBook try building with

   make EXTRA_AR_ARGS=-s

It's a known bug with Cabal.


> ------------------------------------------------
>  x86 build output
> ------------------------------------------------
> ../compiler/stage1/ghc-inplace -no-user-package-conf -cpp
> stage2/ghc-inplace.c -o stage2/ghc-inplace
> ld: in /Users/leather/Projects/ghc-stable/ghc/libraries/haskell98/ 
> dist/build/libHShaskell98-,
> archive has no table of contents
> collect2: ld returned 1 exit status
> make[2]: *** [stage2/ghc-inplace] Error 1
> make[1]: *** [stage2] Error 2
> make: *** [bootstrap2] Error 2

More information about the Glasgow-haskell-users mailing list