GHC 6.6.1 Build failure on plain vanilla linux i686 build

Robin Bate Boerop robin_bb at
Thu Jun 28 14:58:32 EDT 2007

Ian, indeed ghc --version was what you expected.  Thank you for the
advice.  My build continues....

Was my 6.4.2 installed or configured improperly, so that the --version
string was wrong?

On 28/06/07, Ian Lynagh <igloo at> wrote:
> Hi Robin,
> On Fri, Jun 22, 2007 at 01:21:00AM -0300, Robin Bate Boerop wrote:
> > My build dies very soon after issuing "make".  Here are the last few
> > lines.  Does anyone know what is happening and how to fix it?  (The
> > floating constant of which the error message speaks is
> > __GHC_PATCHLEVEL__, which is set to 2.20060331.)  I have a working GHC
> > 6.4 installed, BTW.
> What does "/sec/bin/ghc --version" say? I suspect it'll be
> rather than 6.4.2.
> The simplest thing to do is just to remove all the content of
> compat/cbits/unicode.c (assuming you do have something > 6.4; if you
> have 6.4 itself (or something older) then you'll need to leave the
> #include line in the file, but remove the #if and #endif).
Robin Bate Boerop

More information about the Glasgow-haskell-users mailing list