ANNOUNCE: GHC 6.6 Second Release Candidate

Duncan Coutts duncan.coutts at
Sun Oct 8 20:11:45 EDT 2006

On Sun, 2006-10-08 at 18:55 -0500, Brian Smith wrote:
> On 10/2/06, Ian Lynagh <igloo at> wrote:
>         We are pleased to announce the Second Release Candidate phase
>         for GHC 6.6.
> I am using release candidate 2. I noticed some problems with Cabal, so
> I uninstalled 1.1.4 and installed the latest version from the Darcs
> repository. Now, programs that use the GHC library won't build: 
> ghc.exe: unknown package: Cabal-1.1.4 (dependency of ghc-6.5.20061001)
> Does the ghc package really need exactly version 1.1.4? If so, then
> the Cabal README should be changed, because it tells people to
> uninstall old versions of Cabal before installing new versions. 

A compiled package needs exactly the version of its deps that it was
built against. So you can't remove a dependent package without
rebuilding the packages that depend on it.

> From the README (
> This is the recommended method of installing Cabal.
> If you have an older version of Cabal installed, you probably just
> want to remove it:
>   $ ghc-pkg unregister Cabal

Yes, you're quite right. We should advise people to keep the old version
about. It should be no problem to have several versions installed.

It might also be helpful if ghc-pkg warned if you're unregistering a
package that other packages depend upon.


More information about the Glasgow-haskell-users mailing list