Problem running X11 on PPC Mac

Deborah Goldsmith dgoldsmith at
Sun Nov 5 15:08:08 EST 2006

This problem pops up sometimes for all sorts of open source software  
(try Googling _printf$LDBLStub), and can be due to mixing modules  
compiled by gcc 3.3 and gcc 4.0, and/or due to failure to link with - 

I've had good luck using X11 with GHC if I launch it first, and run  
GHC from inside Xterm rather than Terminal. That way you don't need  
to fiddle with DYLD_LIBRARY_PATH. I haven't tried it on PPC, though,  
just Intel. I'll try it at work tomorrow.

You might want to do "gcc_select" and see which version of gcc is the  
default on your system, though is likely not the issue since you had  
problems with the binary distribution.


On Nov 5, 2006, at 7:23 AM, Melissa Chase wrote:

> I'm new to Haskell (and GHC) and am not sure if this is the  
> appropriate place to post this (or if it should be reported as a  
> bug). Yesterday I downloaded the binary build of 6.6 for the PPC  
> Mac. I am running Mac OSX 10.4.8. I have XCode 2.4.1 and X11 1.1  
> installed.
> I was trying to get the graphics for SOE working and tried the  
> first SimpleGraphics module. I used "import Graphics.SOE" and once  
> I discovered that I had to set DYLD_LIBRARY_PATH to the X11  
> libraries (in /usr/X116/lib), the module loaded in ghci. When I  
> tried to run main0, I got the following error message:
> 	Loading package X11-1.1 ... linking ... <interactive>:
> /opt/local/lib/ghc-6.6/HSX11_cbits.o: unknown symbol `_printf 
> $LDBLStub'
> ghc-6.6: unable to load package `X11-1.1'
> I ran nm on that object file and the symbol appears in it as  
> undefined, and is not defined in any of the .o or .a files in the  
> ghc lib directory.
> I subsequently built the DarwinPorts version of ghc 6.6 and have  
> the same problem.
> Penny
> _______________________________________________
> Glasgow-haskell-users mailing list
> Glasgow-haskell-users at

More information about the Glasgow-haskell-users mailing list