Problem running X11 on PPC Mac

Melissa Chase mpchase at
Sun Nov 5 10:23:39 EST 2006

I'm new to Haskell (and GHC) and am not sure if this is the  
appropriate place to post this (or if it should be reported as a  
bug). Yesterday I downloaded the binary build of 6.6 for the PPC Mac.  
I am running Mac OSX 10.4.8. I have XCode 2.4.1 and X11 1.1 installed.

I was trying to get the graphics for SOE working and tried the first  
SimpleGraphics module. I used "import Graphics.SOE" and once I  
discovered that I had to set DYLD_LIBRARY_PATH to the X11 libraries  
(in /usr/X116/lib), the module loaded in ghci. When I tried to run  
main0, I got the following error message:

	Loading package X11-1.1 ... linking ... <interactive>:
/opt/local/lib/ghc-6.6/HSX11_cbits.o: unknown symbol `_printf$LDBLStub'
ghc-6.6: unable to load package `X11-1.1'

I ran nm on that object file and the symbol appears in it as  
undefined, and is not defined in any of the .o or .a files in the ghc  
lib directory.

I subsequently built the DarwinPorts version of ghc 6.6 and have the  
same problem.


More information about the Glasgow-haskell-users mailing list