Compile problem on Windows

Robert Dockins robdockins at
Fri Jul 14 12:09:08 EDT 2006

I posted a message on the libraries list a couple of days ago about a  
compile problem I'm having.  I haven't got any nibbles.  Because I  
now suspect this is a GHC problem, I'm posting here to see it I can  
get this resolved.  Rather than repost the details, allow me to refer  
you to ( 
4873) which contains a complete description of the problem.  As far  
as I can tell, the GHC install is missing a necessary system header,  
or it isn't being found, or somesuch.  I tried crawling through the  
headers to find out what the problem is, but, as per usual, the  
system headers are almost totally incomprehensible.

I've tried using both Cygwin and MSYS shells, but the results are  
identical.  As I said in the above message, I'm not very familiar  
with this environment, so I'd appreciate pointers in the correct  
direction if I've made some mistake.


Rob Dockins

Speak softly and drive a Sherman tank.
Laugh hard; it's a long way to the bank.
           -- TMBG

More information about the Glasgow-haskell-users mailing list