6.2.1 for glibc-2.4

Simon Marlow simonmarhaskell at gmail.com
Tue Apr 18 06:46:55 EDT 2006

[ replaying on glasgow-haskell-users at haskell.org ]

Paul A. Steckler wrote:
> [Apologies for the cross-post from Haskell Cafe, but I got no responses
> there.]
> I need a Linux ghc 6.2.1 built with glibc-2.4.  The existing 6.2.1 RPM,
> built with glibc-2.3, works mostly OK, but with some programs, the
> generated executables barf and die on startup.  
> Any suggestions on how to create such a beast?
> I've tried using ghc 6.4.1, for which there's a Fedora 5 RPM, to build
> 6.2.1 from source, but all sorts of compile errors occur.  

It's not always possible to build old releases using newer releases, I 
wouldn't be surprised if this didn't work.

Why do you need 6.2.1 specifically?  Perhaps you can fix your client 
code and use 6.4.1 (or 6.4.2) instead?


More information about the Glasgow-haskell-users mailing list