.hc files for building ghc-6.4.1 on amd64 ?

Wilhelm B. Kloke wb at arb-phys.uni-dortmund.de
Tue Sep 20 07:24:19 EDT 2005

Wilhelm B. Kloke <wb at arb-phys.uni-dortmund.de> schrieb:
> Simon Marlow <simonmar at microsoft.com> schrieb:
>> On 17 September 2005 22:05, Wilhelm B. Kloke wrote:
>>> I tried to go back to ghc/rts to build more files following the
>>> ipattern of the last steps before, but this destroys genapply.
>> Don't quite understand this - could you elaborate?
> I tried
>> (cd ghc/rts ; gmake all)
> after (cd ghc/compiler ; gmake stage=2 )

Small, but possibly essential, correction:
"after completion of the whole other stuff".

> I have further information now. When compiling Linker.c,
> the compilation fails, because there is no MAP_32BIT in FreeBSD-amd64.
> Perhaps just removing this could make it work. I have no idea
> why it is needed on linux-x86_64.

Deletion of Linker.c and manual build of some AutoApply files make
the crossbuild work on i386 side. I have a copy of the
resulting hc-bundle ready. If anybody wants them, send me a mail.
They don't work on the amd64 side, though. Here is the error message:

gcc -x c GHC/Int.hc -o GHC/Int.o -c -O  -DNO_REGS -DUSE_MINIINTERPRETER  -D__GLASGOW_HASKELL__=604  -O -I/data/home/wb/Haskell/fptools-amd64/ghc-6.4.1/ghc/includes -I/data/home/wb/Haskell/fptools-amd64/ghc-6.4.1/libraries/base/include -I/data/home/wb/Haskell/fptools-amd64/ghc-6.4.1/libraries/unix/include -I/data/home/wb/Haskell/fptools-amd64/ghc-6.4.1/libraries/parsec/include  -I/data/home/wb/Haskell/fptools-amd64/ghc-6.4.1/libraries/readline/include    -I.  `echo  | sed 's/^$/-DSTOLEN_X86_REGS=4/'`
GHC/Int.hc: In function `s83O_ret':
GHC/Int.hc:2522: error: `int64ToIntegerzh_fast' undeclared (first use in this function)
GHC/Int.hc:2522: error: (Each undeclared identifier is reported only once
GHC/Int.hc:2522: error: for each function it appears in.)
GHC/Int.hc: In function `s83J_ret':
GHC/Int.hc:2583: error: `int64ToIntegerzh_fast' undeclared (first use in this function)
gmake[1]: *** [GHC/Int.o] Fehler 1
gmake: *** [all] Fehler 1
gmake: Leaving directory `/data/home/wb/Haskell/fptools-amd64/ghc-6.4.1/libraries'

I notices that the evil mangler was replaced after my build. I don't have
an idea whether this would make it work.

BTW. FreeBSD-amd64 does not seem to support "small memory model". Is this
Dipl.-Math. Wilhelm Bernhard Kloke
Institut fuer Arbeitsphysiologie an der Universitaet Dortmund
Ardeystrasse 67, D-44139 Dortmund, Tel. 0231-1084-257

More information about the Glasgow-haskell-users mailing list