Can't compile GHC

Daniel Carrera dcarrera at
Mon May 9 09:54:32 EDT 2005


I've been trying to learn Haskell.

Some software isn't user friendly. But I think that a compiler requiring 
itself to compile is actively user hostile. I've spent over a week 
trying to get GHC to work on my Solaris workstation and I've concluded 
that it just isn't going to happen.

I tried to compile GHC but it said taht it needed GHC to compile.

I read the README trying to find out what people without ghc are 
supposed to do to install ghc. But no instructions are found.

I check the website, hoping to find a binary. I find an old binary, but 
it just won't work. Something about

After a lot of work, I got another Haskell compiler, NHC98. Hoping that 
would do, I tried to compile GHC again. No luck.

I read something about .hc files. I look everywhere in the source 
distribution, but no .hc files are to be found.

I go back to the website. Read the building guide section on "porting" 
Why would I read that? I don't want to port it, I just want to compile 
it on a platform it's already been ported to.

The porting page says that the source distribution has ANNOUNCE files 
that tell me where to get the .hc files. I wonder why it didn't just 
tell me directly, but oh well, I go back to the source distribution.

It turns out the building guide was lying. The ANNOUCE file doesn't say 
anything about .hc files or where to get them.

I find the file distrib/hc-build. I figure I might as well try it. 
Nothing to lose. But nope, that didn't do it either.

At this point I really wonder why the compiler was designed this way 
instead of doing the configure; make; make install that everyone else 
does. It's not often that it takes me more than a week to compile a program.

At this point I decide that I'll teach people Python instead of Haskell. 
I don't particularly like Python, but hey, it works.


More information about the Glasgow-haskell-users mailing list