Cabal and older versions of GHC

ross at ross at
Tue Jul 12 20:01:29 EDT 2005

On Mon, Jul 11, 2005 at 09:17:50AM -0400, Dimitry Golubovsky wrote:
> Is it possible to use Cabal with older versions (e. g. 6.0 to 6.2.2) of GHC?

Cabal works with 6.2 (I haven't tried 6.0, but that might work too).
For all but the most complex packages, you need only a basic setup
script bundled with a copy of the library.  I've placed one at

That builds a program that can be used as a Cabal setup script for most
packages, including Cabal itself.

More information about the Glasgow-haskell-users mailing list