scott west swest3 at
Mon May 31 12:31:17 EDT 2004

    I was just trying to cross compile ghc for my new amd64 box and was 
just wondering to what stage others have gotten with it? Personally I 
get a working ghc-inplace, and then I've tried to methods, neither of 
which work. First, I get a fresh source tree (all compilations were with 
6.2.1) and do a configure passing --with-ghc=/path/to/ghc-inline, this 
works pretty well for a while, and eventually it cops out when it tries 
to find Data.Array and can't. Tried some other things with this method 
and they only got me marginally furhter (but I'm fairly sure it wasn't 
the proper way to go about it).

Next, I tried, after using the supplied hc-boot script (which did 
complete), to do a make install... this also fails with:
ghc-6.2.1: error: directory portion of "stage2/absCSyn/AbsCSyn.o" does 
not exist (used with "-o" option.)

So stage2 isn't there, I verified that, but i'm not really familiar 
enough to know when/where it is created. Can anyone shed any light on 
this? Thanks!

More information about the Glasgow-haskell-users mailing list