Error invoking compiler

Andrei Formiga andrei.formiga at
Sat Jul 10 17:39:45 EDT 2004

   I solved the problem. The eclipse plugin built the command line by
creating an array with all the tokens and using it as a parameter for
the Java exec. One of the items in the array was an empty string; I
don't know exactly why, but with this ghc thought it was receiving
more than a source file argument. Well, that's it... don't know if
it's important to the ghc team, but the funny thing is that it worked

[]s, Andrei de A. Formiga

On Sat, 10 Jul 2004 18:12:36 -0300, Andrei Formiga
<andrei.formiga at> wrote:
>    Hi,
>    I'm working with the Haskell plugin for eclipse, but when building
> a project the compiler outputs the following error:
> ghc-6.2.1: can't apply -o to multiple source files
> Usage: For basic information, try the `--help' option.
>    and this is the command line (or should be):
> ghc --make  -odir /home/ktulu/eclipse/runtime-workspace/Hello/out
> -hidir /home/ktulu/eclipse/runtime-workspace/Hello/out -o
> /home/ktulu/eclipse/runtime-workspace/Hello/bin/theResult Main.hs
>    funny enough, when using the same command line at a terminal, it
> compiles ok.
>    Does someone have any thought or ideas on why this is happening ?
>    I'm running GHC 6.2.1 on linux (Fedora Core 2, glibc 2.3),
> installed from RPM. The same problem was reported on other linux
> versions and on Mac OS X. It worked fine on previous versions.
>    Thanks in advance for any help.
> --
> []s, Andrei de A. Formiga

[]s, Andrei de A. Formiga

More information about the Glasgow-haskell-users mailing list