Problem with ghc on Windows ME

Gour gour at
Fri Jan 30 12:41:55 EST 2004

Simon Peyton-Jones (simonpj at wrote:

> Simon and I spent an hour getting to the bottom of Gour's problem. 

Thank you very much for taking the issue. It's very much appreciated.

> Simon M sent round a source patch yesterday.  It'd be great if someone
> could confirm that it really works.

I applied your patch to my 6.2 source tree in my attempt to build 6.2 from
source in MSYS/MinGW environment and so far - it looks good. I can invoke
ghc-inplace and get:

$ /ghc/ghc-6.2/ghc/compiler/stage1/ghc-inplace
Glasgow Haskell Compiler, Version 6.2, for Haskell 98, compiled by GHC version 6.0.1
Using package config file: c:\ghc\ghc-6.2\ghc\driver\package.conf.inplace

==================== Packages ====================
   {name = "rts",
    auto = False,
    import_dirs = [],
    source_dirs = [],
    library_dirs =
      ["c:/ghc/ghc-6.2/ghc/rts", "c:/ghc/ghc-6.2/ghc/rts/gmp"],
    hs_libraries = ["HSrts"],
    extra_libraries = ["m", "gmp", "wsock32", "mingwex"],
    include_dirs = ["c:/ghc/ghc-6.2/ghc/includes"],
    c_includes = ["Stg.h"],
    package_deps = [],
    extra_ghc_opts = [],
    extra_cc_opts = [],
    extra_ld_opts =
    framework_dirs = [],
    extra_frameworks = []}

Hsc static flags: -static
*** Deleting temp files
c:\ghc\ghc-6.2\ghc\compiler\stage1\ghc.exe: no input files
Usage: For basic information, try the `--help' option.

(I don't have cygwin installed so I'm waiting for a new *.msi to test more

However, I hit another problem in my build problem  - pls. see "MSYS build"
thread in cvs-ghc.


gour at
Registered Linux User #278493

More information about the Glasgow-haskell-users mailing list