Difficulties compiling hmake / HaXml

Lescher Christian christian.lescher@icn.siemens.de
Thu, 29 Mar 2001 17:23:10 +0200

I tried to change the "configure" file as you described -- and after "./configure" and "make" I still get the same error message (see above).

What can I do now? Is there another way to use HaXml on Win/Cygwin with GHC?

Cheers, Christian

sh-2.04$ make
cd src/hmake;          make HC=ghc install
make[1]: Entering directory `/test-hmake/hmake-2.02/src/hmake'
make[1]: Nothing to be done for `install'.
make[1]: Leaving directory `/test-hmake/hmake-2.02/src/hmake'
cd src/interpreter;    make HC=ghc install
make[1]: Entering directory `/test-hmake/hmake-2.02/src/interpreter'
/test-hmake/hmake-2.02/script/hmake -ghc HInteractive -d/test-hmake/hmake-2.02/t

Fail: Can't find module Posix in
  Or in standard libraries at
  Asked for by: HmakeConfig.hs
[Check settings of -I or -P flags?]

Stop - hmake dependency error.
make[1]: *** [/test-hmake/hmake-2.02/lib/ix86-CYGWIN_NT-4.0/HInteractive.exe] Er
ror 1
make[1]: Leaving directory `/test-hmake/hmake-2.02/src/interpreter'
make: *** [targets/ix86-CYGWIN_NT-4.0/hmake_g] Error 2