GHC 5.00.2 RPM apparently circular dependency demands

Jon Fairbairn
Tue, 26 Jun 2001 11:24:43 +0100

> Here is the data I have recorded. Perhaps different installation parame=
ters =

> are required?

I don't have the rpms to hand to check the dependencies, but
what you say doesn't on its own point to a problem with the

> Redhat Linux 6.2, I686 SMP
> Glasgow Haskell Compilation System, version 5.00.1
> rpm --version
> RPM version 4.0.2
> =

> rpm -U ghc-5.00.2-rh62-1.i386.rpm
> error: failed dependencies:
>          ghc =3D 4.08 is needed by ghc-prof-4.08-1
>          ghc =3D 5.00.1 is needed by ghc-prof-5.00.1-1

This implies that you have ghc-prof-4.08-1 installed, and it
does need ghc 4.08. Similarly ghc-prof-5.00.1-1.  Using -U
means update, and it wants to remove older versions of the
package mentioned, but it can't since that would break
dependencies for ghc-prof, which you haven't asked it to

rpm -U ghc-5.00.2-rh62-1.i386.rpm ghc-prof-5.00.2<whatever>

ought to have worked, although you may need to do something
about having _two_ versions of ghc-prof installed (rpm -e to

> rpm -i --force ghc-5.00.2-rh62-1.i386.rpm

That was a bad idea!

> Segmentation fault (core dumped)

That indicates a bug in rpm! You should report it with
bugzilla. It's possible that this might have done something
bad to your rpm database :-(. Try rpm --rebuilddb and if
that fails, restore it from backups.


-- =

J=F3n Fairbairn                       
31 Chalmers Road                               
Cambridge CB1 3SZ            +44 1223 570179 (after 14:00 only, please!)