GHC 5.00.2 RPM apparently circular dependency demands

Byron Hale
Mon, 25 Jun 2001 22:46:19 -0700


This is probably ignorance on my part, but I am having trouble installing 
with the new RPMs.

Here is the data I have recorded. Perhaps different installation parameters 
are required?

Redhat Linux 6.2, I686 SMP
Glasgow Haskell Compilation System, version 5.00.1
rpm --version
RPM version 4.0.2

rpm -U ghc-5.00.2-rh62-1.i386.rpm
error: failed dependencies:
         ghc = 4.08 is needed by ghc-prof-4.08-1
         ghc = 5.00.1 is needed by ghc-prof-5.00.1-1

rpm -i --force ghc-5.00.2-rh62-1.i386.rpm
Segmentation fault (core dumped)

Thanks in advance.

Byron Hale