GHC Alpha port?

Ken Shan
Wed, 4 Jul 2001 14:28:20 -0400

Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

OK-- I'm probably not the most qualified person to try to port GHC to
the Alpha, but my attempt begins...

To get started, I want to generate .hc files using my existing
ghc-5.00.2 installation on my i386-unknown-linux box.  I tried to
follow the steps in

as follows.  First I create a shadow directory tree and configure:

    mkdir c1 c1-obj
    cd c1
    lndir ../ghc-5.00.2
    ./configure --prefix=3D$PWD-obj

Second I create c1/mk/

    GhcHcOpts    +=3D -H24m -keep-hc-files-too -optc-DNO_REGS -optc-DUSE_MI=
NIINTERPRETER -fno-asm-mangling -funregisterised -fvia-C
    GhcRtsHcOpts +=3D                          -optc-DNO_REGS -optc-DUSE_MI=
NIINTERPRETER -fno-asm-mangling -funregisterised -fvia-C
    SplitObjs     =3D NO

Then I ran "make".  It stopped in c1/ghc/rts, at:

    ../../ghc/compiler/ghc-inplace -optc-O -optc-O2 -optc-fomit-frame-point=
er -optc-Wall -optc-W -optc-Wstrict-prototypes -optc-Wmissing-prototypes -o=
ptc-Wmissing-declarations -optc-Winline -optc-Waggregate-return -optc-Wbad-=
function-cast -optc-DCOMPILING_RTS -ldl -I../includes -I. -Iparallel -O2 -o=
ptc-DNO_REGS -optc-DUSE_MINIINTERPRETER -fno-asm-mangling -funregisterised =
-fvia-C -DCOMPILING_RTS -static -c Adjustor.c -o Adjustor.o
    Segmentation fault (core dumped)

Indeed, even running ../../ghc/compiler/ghc-inplace by itself, or
running c1/ghc/compiler/ghc-5.00.2 by itself, gives a seg fault.

Being unfamiliar with the build system, I would appreciate any advice
on how to debug this problem.  Or has the .hc generation procedure
changed between ghc4 and ghc5?

Edit this signature at

Content-Type: application/pgp-signature
Content-Disposition: inline

Version: GnuPG v1.0.6 (GNU/Linux)
Comment: For info see