GHC for RedHat 7.0 (gcc 2.96)

Manuel M. T. Chakravarty
Wed, 18 Oct 2000 20:06:26 +1100

GHC (4.08.1) rpm packages for RedHat 7.0 are available from

[The second package is only required for profiling.]

The corresponding source rpm is at


For this to work, you have to additionally install on old
version (2.0) of the GNU Multiprecision Library (GMP).  Get
it off your old RedHat 6.2 CD or alternatively from

* You have to install *both* packages.

* They can co-exist with the new library (version 3.0)
  installed by default with RedHat 7.0.

NOTE: These packages cannot be installed on RedHat 6.2 and
      earlier (unless you manually upgrade to the rpm
      package manager 4.0).

Happy Hacking,

PS: Could these packages be linked from GHC's download page?
    And please also add the comment and links re gmp 2.0.
    Moreover, please *don't* remove the old links for the
    benefit of RH6.2 users.