[GHC] #4108: GHC.Integer.hashInteger is a misnomer and confuses people

GHC cvs-ghc at haskell.org
Sun May 30 18:14:00 EDT 2010


#4108: GHC.Integer.hashInteger is a misnomer and confuses people
---------------------------+------------------------------------------------
  Reporter:  duncan        |          Owner:                  
      Type:  bug           |         Status:  closed          
  Priority:  normal        |      Milestone:                  
 Component:  Compiler      |        Version:  6.12.2          
Resolution:  invalid       |       Keywords:                  
Difficulty:                |             Os:  Unknown/Multiple
  Testcase:                |   Architecture:  Unknown/Multiple
   Failure:  None/Unknown  |  
---------------------------+------------------------------------------------
Changes (by igloo):

  * status:  new => closed
  * resolution:  => invalid


Comment:

 I agree with Eric.

 Hard to say more without knowing which package you are talking about, and
 what it expects `hashInteger` to do.

-- 
Ticket URL: <http://hackage.haskell.org/trac/ghc/ticket/4108#comment:2>
GHC <http://www.haskell.org/ghc/>
The Glasgow Haskell Compiler


More information about the Glasgow-haskell-bugs mailing list