[GHC] #4108: GHC.Integer.hashInteger is a misnomer and confuses
people
GHC
cvs-ghc at haskell.org
Sun May 30 18:03:07 EDT 2010
#4108: GHC.Integer.hashInteger is a misnomer and confuses people
---------------------------------+------------------------------------------
Reporter: duncan | Owner:
Type: bug | Status: new
Priority: normal | Component: Compiler
Version: 6.12.2 | Keywords:
Os: Unknown/Multiple | Testcase:
Architecture: Unknown/Multiple | Failure: None/Unknown
---------------------------------+------------------------------------------
Comment(by guest):
It seems to me that this function serves perfectly well as a hash
function.
A hash function is any well-defined procedure or mathematical function
that converts a large, possibly variable-sized amount of data into a small
datum, usually a single integer that may serve as an index to an array.
— Wikipedia
It seems to me that this function evenly distributes the integers among
the Ints and is fast
--
Eric Mertens
--
Ticket URL: <http://hackage.haskell.org/trac/ghc/ticket/4108#comment:1>
GHC <http://www.haskell.org/ghc/>
The Glasgow Haskell Compiler
More information about the Glasgow-haskell-bugs
mailing list