Can't push to staging area?

Brandon Allbery allbery.b at
Thu Jan 4 01:05:19 UTC 2018

"sudo: a password is required"

Can't even tell if that's local (beware e.g. Ubuntu defaults) or remote
(which would be a configuration problem on the remote end, not to mention
seeming like a bad idea).

On Wed, Jan 3, 2018 at 6:36 PM, Bartosz Nitka <niteria at> wrote:

> I'm trying to update a diff and I run into this:
> $ arc diff
> Linting...
>  LINT OKAY  No lint problems.
> Running unit tests...
> No unit test engine is configured for this project.
>  PUSH STAGING  Pushing changes to staging area...
> sudo: a password is required
> fatal: Could not read from remote repository.
> Please make sure you have the correct access rights
> and the repository exists.
>  STAGING FAILED  Unable to push changes to the staging area.
> Usage Exception: Failed to push changes to staging area. Correct the
> issue, or use --skip-staging to skip this step.
> I believe that it worked for me before with my setup, and I seem to be
> in compliance with
> Fixingabugsubmittingareview
> Any ideas?
> Thanks,
> Bartosz
> _______________________________________________
> ghc-devs mailing list
> ghc-devs at

brandon s allbery kf8nh                               sine nomine associates
allbery.b at                                  ballbery at
unix, openafs, kerberos, infrastructure, xmonad
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the ghc-devs mailing list