msys2 64 bit: help help!

Simon Peyton Jones simonpj at
Tue Jun 28 12:47:18 UTC 2016

David, Tamar

Thanks for your help.  I'm a bit further forward.

|  > 1.  I just left the machine for 10-15 mins and lo! the shell windows
|  opened up. It just took a loooong time.
|  I could be something with Active Directory. Cygwin (upon which is
|  MSYS2 based) integrates with AD, but there are numerous (google-able)
|  reports of huge slowdowns related to this.

|  > 4. As you mention, I then tried msys2_shell.cmd.  It worked -- with
|  a noticeable delay of 5 seconds or so.
|  May still be AD-related.

Let's suppose it is AD.  Do you have any idea what I can do about it?

|  If the post-install script for `filesystem` were able to run, it would
|  inform you that `*_shell.bat` are deprecated and were removed. I see
|  you have `msys2-launcher-git` installed -- you can then use
|  `C:\msys64\mingw64.exe` (and even pin it to the taskbar).

OK... so forget msys2_shell.cmd and use mingw64.exe instead.  I'll try that.

|  > * how can I debug what's happening with
|  >   that long delay
|  `/etc/nsswitch.conf` allows for some configuration. See
|  <
|  pwdgrp>.

OK.. I see that page. Now what?  What might I do with nsswitch.conf that might help fix or give insight?


More information about the ghc-devs mailing list