msys2 64 bit: help help!

David Macek david.macek.0 at
Tue Jun 28 12:19:34 UTC 2016

On 27. 6. 2016 23:33, Simon Peyton Jones via ghc-devs wrote:
> 1.  I just left the machine for 10-15 mins and lo! the shell windows opened up. It just took a loooong time.

I could be something with Active Directory. Cygwin (upon which is MSYS2 based) integrates with AD, but there are numerous (google-able) reports of huge slowdowns related to this. 

> At this point, starting a new shell no longer took a long time.  It all seemed to be working.

Also don't forget to exclude `C:\msys64` from any anti-virus scans.

> 2.  I then ran pacman -Syuu as instructed on the installation page:

I'm afraid you misread the instructions. You should run `update-core` first to upgrade to the newer pacman that handles `pacman -Syuu` correctly. (New installer packages with an up-to-date pacman are planned.)

> The log of what happened is below.  There are numerous failures involving Cygwin, which I do not have installed, at least not so far as I know.   I do not know if these failures matter.

They might. See below.

> 3. After this step, starting a shell failed altogether with "c:/msys64/mingw64_shell.bat is not recognised as an internal or external command". And sure enough, there is no such file. Presumably it existed in step 1.  So perhaps step 2 deleted it?

If the post-install script for `filesystem` were able to run, it would inform you that `*_shell.bat` are deprecated and were removed. I see you have `msys2-launcher-git` installed -- you can then use `C:\msys64\mingw64.exe` (and even pin it to the taskbar).

> 4. As you mention, I then tried msys2_shell.cmd.  It worked -- with a noticeable delay of 5 seconds or so.

May still be AD-related.

> * should I worry about all those install errs

I recommend staying on the safe side and nuke the installation. Alternatively, reinstall the packages that had failures (`pacman -S gcc-libs gettext gmp ...`). 

> * how can I debug what's happening with 
>   that long delay

`/etc/nsswitch.conf` allows for some configuration. See <>.

> * Should I nuke the start menu shortcuts that
>   the msys64 installer so carefully installed
>   in favour of msys2_shell.cmd?

Yes or see above. Note that you might need `msys2_shell.cmd -mingw64` instead (not sure if it matters for GHC).

David Macek

-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 3834 bytes
Desc: S/MIME Cryptographic Signature
URL: <>

More information about the ghc-devs mailing list