Why upper bound version numbers?
hesselink at gmail.com
Tue Jun 7 08:43:14 UTC 2016
Others have already commented on many aspects of this discussion, but
I just wanted to mention that cabal has an '--allow-newer' flag to
disregard these constraints, so '--allow-newer=base' would allow you
to try and compile this package with GHC 8. Since GHC 8 is very recent
though and base 4.3 is very old, I imagine it won't work. In general I
think many packages haven't been updated for GHC 8 yet.
On 6 June 2016 at 23:02, Dominick Samperi <djsamperi at gmail.com> wrote:
> Why would a package developer want to upper bound the version number
> for packages like base? For example, the clash package requires
> base >= 4.2 && base <= 4.3
> Consequently, it refuses to install with the latest ghc provided with
> the Haskell Platform (8.0.1).
> Does this mean that assuming that future versions of the platform will
> remain backwards compatible with prior versions is unsafe?
> ghc-devs mailing list
> ghc-devs at haskell.org
More information about the ghc-devs