Why upper bound version numbers?

Christiaan Baaij christiaan.baaij at gmail.com
Tue Jun 7 08:29:34 UTC 2016

Given that I'm the maintainer of the 'clash' package, I wanted to say 
that the 'clash' package has been deprecated in favour of the 
'clash-ghc' package (for some time now, and this is stated on hackage).

Sadly, 'clash-ghc' will not compile on ghc 8.0.1 right now either; it 
only compiles against ghc 7.10. I will update the installation 
instructions on the website and in the haddock documentation to mention 
this fact.
A version of 'clash-ghc' that compiles against 8.0.1 is not due for 
another month.

If you have any more questions about installing clash, I strongly 
encourage you to either email me, or the clash-mailing list 
(http://groups.google.com/group/clash-language), and not use this 
mailing list (ghc-devs at haskell.org) for question about clash.



On 06/06/2016 11:02 PM, Dominick Samperi wrote:
> Why would a package developer want to upper bound the version number
> for packages like base? For example, the clash package requires
> base >= 4.2 && base <= 4.3
> Consequently, it refuses to install with the latest ghc provided with
> the Haskell Platform (8.0.1).
> Does this mean that assuming that future versions of the platform will
> remain backwards compatible with prior versions is unsafe?
> Thanks,
> Dominick
> _______________________________________________
> ghc-devs mailing list
> ghc-devs at haskell.org
> http://mail.haskell.org/cgi-bin/mailman/listinfo/ghc-devs

More information about the ghc-devs mailing list