Overlapping names in GHC: ConLike
carter.schonwald at gmail.com
Thu Feb 13 16:48:25 UTC 2014
On Thursday, February 13, 2014, Joachim Breitner <mail at joachim-breitner.de>
> while reading some code I noticed that we use the term “ConLike” for two
> different things: From Haskell up to the desugarer, this is a data type
> to treat data constructors and pattern synonyms together; afterwards, in
> the world of Core, ConLike is an attribute of expression (exprIsConLik)
> similar to exprIsHNF.
> The former use is newer, introduced by the pattern synonym patch. In the
> long run, there is a risk of confusion, maybe we should rename ConLike
> module and data type. Any suggestions for a good name?
> Joachim “nomeata” Breitner
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the ghc-devs