Overlapping names in GHC: ConLike
mail at joachim-breitner.de
Thu Feb 13 10:21:50 UTC 2014
while reading some code I noticed that we use the term “ConLike” for two
different things: From Haskell up to the desugarer, this is a data type
to treat data constructors and pattern synonyms together; afterwards, in
the world of Core, ConLike is an attribute of expression (exprIsConLik)
similar to exprIsHNF.
The former use is newer, introduced by the pattern synonym patch. In the
long run, there is a risk of confusion, maybe we should rename ConLike
module and data type. Any suggestions for a good name?
Joachim “nomeata” Breitner
mail at joachim-breitner.de • http://www.joachim-breitner.de/
Jabber: nomeata at joachim-breitner.de • GPG-Key: 0x4743206C
Debian Developer: nomeata at debian.org
-------------- next part --------------
A non-text attachment was scrubbed...
Size: 181 bytes
Desc: This is a digitally signed message part
More information about the ghc-devs