Git problem

Simon Peyton Jones simonpj at
Mon Apr 14 09:13:02 UTC 2014

I'm stuck with Git. Help please!

I tried to do a 'git stash pop', having just done a 'git pull' from the master repo.  I got this:

simonpj at cam-05-unx:~/code/HEAD-2$ git stash pop

warning: Failed to merge submodule utils/haddock (commits don't follow merge-base)

Auto-merging utils/haddock

CONFLICT (submodule): Merge conflict in utils/haddock

Auto-merging compiler/typecheck/TcRnMonad.lhs
Now git status says

simonpj at cam-05-unx:~/code/HEAD-2$ git status

# On branch master

# Your branch is ahead of 'origin/master' by 2 commits.


# Changes to be committed:

#   (use "git reset HEAD <file>..." to unstage)


#    modified:   compiler/typecheck/TcMType.lhs

#    modified:   compiler/typecheck/TcRnMonad.lhs

#    modified:   compiler/typecheck/TcSimplify.lhs

#    modified:   compiler/typecheck/TcUnify.lhs


# Unmerged paths:

#   (use "git reset HEAD <file>..." to unstage)

#   (use "git add/rm <file>..." as appropriate to mark resolution)


#    both modified:      utils/haddock
The modified files are right.  It's the "both modified utils/haddock" that is messing me up.
I'm not modifying haddock!  I just want to say "take the master haddock", but I don't know how.  I tried 'git checkout utils/haddock' but that just led do `git status' saying

#    modified:   utils/haddock (new commits)

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the ghc-devs mailing list