Windows build failures in FD.hs

Edsko de Vries edskodevries
Tue Oct 1 16:18:40 UTC 2013

Hi all,

I'm still trying to get a Windows build (Win 7, tried both 32-bit and
64-bit, same result) -- using THREADS=1. When running 'sh validate',
compilation eventually stops with

"inplace/bin/ghc-stage1.exe" -hisuf hi -osuf  o -hcsuf hc -static
-H32m -O -Werror -Wall -H64m -O0    -package-name base-
-hide-all-packages -i -ilibraries/base/.
-Ilibraries/base/dist-install/build/autogen -Ilibraries/base/include
-optPlibraries/base/dist-install/build/autogen/cabal_macros.h -package
ghc-prim- -package integer-gmp- -package rts-1.0
-package-name base -XHaskell2010 -O2 -O -dcore-lint -fno-warn-amp
-fno-warn-deprecated-flags  -no-user-package-db -rtsopts      -odir
libraries/base/dist-install/build -hidir
libraries/base/dist-install/build -stubdir
libraries/base/dist-install/build  -dynamic-too -c
libraries/base/./GHC/IO/FD.hs -o
libraries/base/dist-install/build/GHC/IO/FD.o -dyno

libraries\base\GHC\IO\FD.hs:281:23: Empty 'do' block

libraries\base\GHC\IO\FD.hs:282:23: Empty 'do' block

libraries\base\GHC\IO\FD.hs:283:26: Not in scope: `devptr'

libraries\base\GHC\IO\FD.hs:283:33: Not in scope: `inoptr'

libraries\base\GHC\IO\FD.hs:284:20: Not in scope: `devptr'

libraries\base\GHC\IO\FD.hs:284:34: Not in scope: `inoptr'
make[1]: *** [libraries/base/dist-install/build/GHC/IO/FD.o] Error 1
make: *** [all] Error 2

Since nobody else seems to be experiencing this, there must be
something wrong with my setup? I've tried to follow best
I could, but I'm not a Windows user so I might have got something

Any suggestions welcome!


More information about the ghc-devs mailing list