Cannot make ghc: Failed to load interface for GHC.Base

Dan Rosén danr at
Thu Aug 29 12:20:15 CEST 2013

Dear devs,

I'm getting this build error when compiling GHC:

"inplace/bin/ghc-stage1" -hisuf hi -osuf  o -hcsuf hc -static  -H64m -O0
-fasm    -package-name ghc-prim- -hide-all-packages -i
-ilibraries/ghc-prim/. -ilibraries/ghc-prim/dist-install/build
-Ilibraries/ghc-prim/dist-install/build/autogen -Ilibraries/ghc-prim/.
-optPlibraries/ghc-prim/dist-install/build/autogen/cabal_macros.h -package
rts-1.0 -package-name ghc-prim -XHaskell98 -XCPP -XMagicHash
-XForeignFunctionInterface -XUnliftedFFITypes -XUnboxedTuples
-XEmptyDataDecls -XNoImplicitPrelude -O -fasm  -no-user-package-db
-rtsopts      -odir libraries/ghc-prim/dist-install/build -hidir
libraries/ghc-prim/dist-install/build -stubdir
libraries/ghc-prim/dist-install/build  -dynamic-too -c
libraries/ghc-prim/./GHC/Types.hs -o
libraries/ghc-prim/dist-install/build/GHC/Types.o -dyno

    Failed to load interface for 'GHC.Base'
    There are files missing in the 'base' package,
    try running 'ghc-pkg check'.
    Use -v to see a list of the files searched for.
make[1]: *** [libraries/ghc-prim/dist-install/build/GHC/Types.o] Error 1

I uploaded a full log of (perl boot && ./configure && make) here: (3MB)

At lines 2515- I can see this:

"/home/dan/code/ghc/inplace/bin/ghc-pkg" update --force
Reading package info from "libraries/base/dist-install/inplace-pkg-config"
... done.
base- Warning: haddock-interfaces:
doesn't exist or isn't a file
base- cannot find any of
base- cannot find any of
["GHC/Base.hi","GHC/Base.p_hi","GHC/Base.dyn_hi"] (ignoring)

Maybe this is related? I don't know if these ignores are expected.

I've tried cloning the repo from and the
github mirror, I'm using the "quick" build flavour, but I've also tried


before GhcLibWays' definition in mk/ without success.

Any ideas what could be wrong?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the ghc-devs mailing list