Upper bound on "time" in Cabal causes build failure

Erik Hesselink hesselink at gmail.com
Wed Dec 17 10:14:36 UTC 2014

It would perhaps be worth it for someone with the right permissions to
edit the (five) old versions on hackage, and add upper bounds. That
way cabal install wouldn't use this very old version assuming it works
(it probably doesn't).


On Wed, Dec 17, 2014 at 10:52 AM, Toby Goodwin <toby at paccrat.org> wrote:
> Hi cabal developers,
> Wasn't sure what best to do with this - please let me know if you'd rather I emailed it elsewhere, or opened an issue against the github project, or...
> I'm trying to build haskell-platform-2014.2 from source, with the latest cabal:
>   cabal-install version
>   using version of the Cabal library
> The build plan it constructs for the hptool sandbox includes Cabal-1.2.4! (That's not a typo.) The problem seems to be that it chooses time-1.5, and then discovers that all recent versions of Cabal have the constraint "time < 1.5", so digs up this fossil from the attic.
> So I think there are two problems here. The small and simple one is that we need a release of Cabal with "time < 1.6" - you appear to have this in the master branch already; can it go on the 1.20 branch? Do you want me to create an issue / pull request?
> The larger problem is that cabal should have found a better build plan. I'm naive about the internals of dependency resolution, but I would have expected it to prefer taking time back 1 release over taking Cabal back 18. It would also be nice if it could have deduced that Cabal-1.2.4 wasn't actually going to build with recent ghc versions.
> Thanks for your time,
> Toby.
> _______________________________________________
> cabal-devel mailing list
> cabal-devel at haskell.org
> http://www.haskell.org/mailman/listinfo/cabal-devel

More information about the cabal-devel mailing list